Issues Accessing Klaviyo.com

Incident Report for Klaviyo

Resolved

Full access to klaviyo.com has been restored. This incident has been resolved.
Posted May 30, 2025 - 16:58 EDT

Monitoring

As of 4:48pm (US Eastern), all pages across klaviyo.com are available and users should no longer be experiencing issues.
Posted May 30, 2025 - 16:49 EDT

Identified

As of 4:39pm (US Eastern), we have identified a fix. Users are able to access klaviyo.com and login successfully.
Posted May 30, 2025 - 16:44 EDT

Investigating

Beginning at 4:21 pm (US Eastern), users began experiencing issues accessing klaviyo.com. API routes are unaffected. We are currently investigating this issue.
Posted May 30, 2025 - 16:36 EDT
This incident affected: Klaviyo.com.