Segment processing delay
Incident Report for Klaviyo
Resolved
As of 10/20/2023 2:25pm EDT all segmentation delays have been resolved and caught up. All functionality should work as expected now.
Posted Oct 20, 2023 - 14:26 EDT
Identified
Since 10/20/2023 12:30pm EDT we began experiencing Segmentation processing delays. Services impacted include: Any updates to segmentations, Flow based segmentation triggers, and/or Forms based on segmentations.

We've confirmed there has been no data loss and we expect a resolution in the next 15 mins on this matter.
Posted Oct 20, 2023 - 14:14 EDT
This incident affected: Segmentation, Flow Triggering, and Signup Forms.