Outage in dashboard reporting
Incident Report for Klaviyo
Resolved
This incident has been resolved.
Posted Feb 26, 2024 - 13:18 EST
Investigating
We have received reports of the Dashboard not loading as expected. Our Engineering Team is currently investigating this and working on releasing a solution as quickly as possible. We will provide updates as we progress.
Posted Feb 26, 2024 - 12:49 EST
This incident affected: Analytics.