Access to klaviyo.com and core platform services has been restored. The majority of platform areas have returned to normal operation, with many affected services recovering automatically as infrastructure came back online. Our team is continuing to monitor platform stability and is actively working through remaining data repairs, including unsubscribe processing and analytics recovery. We will share further updates as this work progresses.
Posted May 06, 2026 - 01:59 EDT
Monitoring
Our engineering team has restored the impacted services and confirmed that systems have resumed functioning as intended. All Campaign/Flow messages impacted which are able to be replayed are currently sending. We're currently monitoring performance and will continue to update as incident is resolved.
Posted May 05, 2026 - 22:53 EDT
Update
We are seeing recovery across APIs, event ingestion, and subscriptions. Our team continues to work toward restoring full functionality.
Posted May 05, 2026 - 21:38 EDT
Update
Recovery is continuing to progress, and additional services are coming back online. Our team remains actively engaged, and we'll provide another update shortly.
Posted May 05, 2026 - 20:57 EDT
Identified
Access to klaviyo.com has been restored, and dependent services are progressively coming back online. Our team continues to work toward full recovery, which we expect within the next hour. We'll provide another update in 30 minutes.
Posted May 05, 2026 - 20:25 EDT
Update
We are continuing to investigate the issue affecting access to klaviyo.com and all associated services. Our engineering team is actively working to restore affected services. We will provide updates as soon as more information is available.
Posted May 05, 2026 - 19:40 EDT
Update
Our engineering team is continuing to investigate the disruption affecting klaviyo.com, our APIs, and message sending. We will provide updates as more information is available.
Posted May 05, 2026 - 18:33 EDT
Investigating
Klaviyo is currently experiencing a service disruption affecting access to klaviyo.com, our APIs, and message sending. Customers may be unable to log in, send campaigns or flows, or have their events processed during this time. Our engineering team is actively investigating the root cause. We'll provide updates as soon as more information is available.