Processing failures affecting multiple services
Incident Report for Klaviyo
Resolved
We have completed monitoring of this incident. Our engineering team is working to restore email and SMS engagement events that were dropped (opens and clicks). These events may take several days to restore.
Posted Oct 24, 2023 - 12:48 EDT
Monitoring
At around 7:10 pm Eastern Time, we experienced an outage in an internal system that impacted several product areas. The system was restored at around 7:30 pm Eastern Time.

We are assessing impacts to the product during this incident. Confirmed impacts during the outage window are listed below. Between 7:10 and 7:20 pm ET, all of the below requests failed. After that time, as our systems recovered, failures were only partial.

-Requests to v3 APIs failed
-Subscribe and Unsubscribe requests to v2 APIs failed
-Form submissions failed
-Requests to create and update segments failed
-A small percentage of email messages failed to deliver
-Some email engagement events, including opens and clicks, may be delayed for several days
-Account usage metrics may be out of date

We are assessing which failed requests can be retried and will update this incident status page accordingly.
Posted Oct 23, 2023 - 20:39 EDT
This incident affected: Klaviyo API, Analytics, Segmentation, List Subscription, and Signup Forms.