Delays in Flow Triggering & Segmentation
Incident Report for Klaviyo
Resolved
This incident has been resolved. We are currently experiencing a new increased delay in real-time segmentation processing that will be tracked here: https://status.klaviyo.com/incidents/ftvglgn9wjvq
Posted Sep 27, 2021 - 10:52 EDT
Monitoring
Real-time segmentation processing is back to real-time. Flow email sending remains on time without delays. We will continue to monitor all systems.
Posted Sep 27, 2021 - 06:35 EDT
Update
We are able to confirm that flow email sending has stayed real-time and remains on time, with Flow triggering for a small subset of Flows no longer impacted by this incident. Real-time segmentation updates continue to be delayed but delays are improving.
Posted Sep 27, 2021 - 05:41 EDT
Identified
We are unfortunately once again seeing accumulated Flow delays due to this incident, with up to 25% of all Flows experiencing triggering delays of up to 1-2 hours. Real-time and manual segmentation updates are also experiencing delays of over an hour. We are actively working to mitigate impact and will provide updates here.
Posted Sep 27, 2021 - 04:44 EDT
Monitoring
We have successfully mitigated the root-cause of this incident and Flow email sending is back to real-time. We will continue to monitor all systems.
Posted Sep 27, 2021 - 00:46 EDT
Identified
We are currently experiencing a delay in Flow email sending, where Flow emails may be delayed up to 45 minutes. We are actively working to resolve this issue and will continue to provide updates here.
Posted Sep 27, 2021 - 00:33 EDT
This incident affected: Segmentation and Flow Triggering.